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ΠΕΡΙΛΗΨΗ 

 

Σκοπός της πτυχιακής εργασίας είναι η δημιουργία μιας εφαρμογής για το 

Διαδίκτυο όπου ο χρήστης θα μπορεί να περιηγείται στο χωριό Νεράιδα. Όταν 

θα βρίσκεται σε ένα σημείο θα έχει οπτική επαφή 360 μοιρών από αριστερά 

προς τα δεξιά. Επίσης θα έχει τη δυνατότητα να προχωρήσει στο επόμενο ή 

προηγούμενο σημείο αναλόγως το που θέλει να πάει. Έτσι θα μπορεί να 

περιηγηθεί εικονικά σε όλους τους δρόμους και να δει ολόκληρο το χωριό σα 

να ήταν εκεί. 

Τα πλεονεκτήματα μιας τέτοιας εφαρμογής είναι ότι οποιοσδήποτε χρήστης 

από όπου κι αν βρίσκεται θα μπορεί να επισκέπτεται το χωριό εικονικά και να 

θαυμάζει τις ομορφιές του από τον υπολογιστή του πριν το επισκεφθεί από 

κοντά. Αυτοί οι λόγοι οδήγησαν στο να αναπτυχθούν εφαρμογές που 

προβάλλουν εξωτερικούς χώρους όπως πόλεις, εξωτικά νησιά, σημεία 

τουριστικού και πολιτισμικού ενδιαφέροντος αλλά και εσωτερικούς χώρους 

όπως μουσεία, κρουαζιερόπλοια, κινηματογραφικά στούντιο, στούντιο 

εκπομπών και πολλά άλλα. 

Για την επίτευξη της εφαρμογής χρειάστηκε μια ψηφιακή φωτογραφική 

μηχανή κι ένας τρίποδας για την λήψη των φωτογραφιών από όλα τα σημεία 

που καλύπτουν ολόκληρο το χωριό. Στη συνέχεια έγινε η επεξεργασία των 

φωτογραφιών, η ένωσή τους και η δημιουργία των τελικών πανοραμάτων στο 

πρόγραμμα Photoshop. Μετά χρησιμοποιήθηκε το πρόγραμμα Pano2VR για 

την ένωση των πανοραμάτων και τη δημιουργία της τελικής εφαρμογής. 

Παρακάτω αναλύονται τα βήματα που ακολουθήθηκαν. 
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ABSTRACT 

 

The purpose of the thesis is to create an application for the Internet where the 

user can browse the village Neraida. When it is a point I make eye contact 

360 degrees from left to right. You will also have the opportunity to move to 

the next or previous item accordingly wants to go. So you can browse virtually 

all the streets and seeing the whole village as if they were there. 

The advantages of such an application is that any user from wherever they 

can visit the virtual village and admiring the beauties of his computer before 

the visit closely. These reasons led me to develop applications that rely 

outdoors as cities, exotic islands, tourist spots and cultural interest and 

interiors such as museums, cruise ships, movie studios, studio shows and 

more. 

To achieve the application had a digital camera and a tripod for taking photos 

of all the points covered the whole village. Then was processed photos, their 

union and the creation of panoramas finished the program Photoshop. After 

Pano2VR program was used for the compound of panoramas and create the 

final application. Below analyzed the steps followed. 
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ΕΙΣΑΓΩΓΗ 

 

Η αυξανόμενη ανάπτυξη εφαρμογών εικονικής περιήγησης και το ότι πόσο 

σημαντική και ενδιαφέρουσα είναι για να αναδείξει τις ομορφιές ενός χωριού 

κίνησαν το ενδιαφέρον και τη δημιουργία αυτής της πτυχιακής. Έτσι 

τοποθετώντας τον τρίποδα με την ψηφιακή φωτογραφική μηχανή έκανα 

διαδοχικές λήψεις σε πολλά σημεία ώστε να καλύψω ολόκληρο το χωριό. 

Στη συνέχεια έκανα επεξεργασία, ένωση και δημιουργία των τελικών 

πανοραμάτων με τη βοήθεια του προγράμματος Photoshop. 

Τέλος χρησιμοποίησα το πρόγραμμα Pano2VR για την ένωση των 

πανοραμάτων και την δημιουργία της τελικής εφαρμογής όπου ο χρήστης θα 

μπορεί να περιηγείται από σημείο σε σημείο. 
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ΚΕΦΑΛΑΙΟ 1 

Πανοραμική απεικόνιση του χώρου 

 

Το πρόβλημα που είχα να αντιμετωπίσω ήταν η δημιουργία μιας ιδιαίτερα 

χρήσιμης εφαρμογής για το Διαδίκτυο όπου οποιοσδήποτε χρήστης από 

όπου κι αν βρίσκεται θα μπορεί να περιηγείται εικονικά σε ολόκληρο το χωριό 

από την άνεση του σπιτιού του. Επίσης η εφαρμογή πρέπει να είναι εύκολη 

στη χρήση, για να μπορεί να χρησιμοποιηθεί από μια ευρεία κατηγορία 

χρηστών αλλά και να κεντρίζει άμεσα το ενδιαφέρον του χρήστη. Επιπλέον 

πρέπει να καλύπτει κάθε γωνιά του χωριού ώστε ο χρήστης να αποκτήσει μια 

πλήρη εικόνα για το χωριό πριν το επισκεφθεί από κοντά. 

Αυτό πραγματοποιείται με την δημιουργία πανοραμικών εικόνων. Οι 

πανοραμικές εικόνες είναι διαδοχικές λήψεις εικόνων έτσι ώστε να 

συμπεριλαμβάνει πολύ περισσότερο από ότι μπορεί να δει φυσικά το 

ανθρώπινο μάτι σε ένα σημείο. Έτσι δημιουργούνται πανοράματα των 180 

μοιρών ή πλήρη πανοράματα των 360 μοιρών. Επίσης μπορούν να 

δημιουργηθούν πανοράματα των 360 μοιρών από αριστερά προς τα δεξιά 

αλλά και από πάνω προς τα κάτω. Έτσι δημιουργούνται πανοράματα όπου ο 

χρήστης έχει μια σφαιρική απεικόνιση του σημείου. Για την δημιουργία της 

εφαρμογής θα γίνει χρήση των πανοραμάτων των 360 μοιρών από αριστερά 

προς τα δεξιά. 

Έτσι όταν θα βρίσκεται σε ένα σημείο, θα μπορεί με το ποντίκι του να 

περιστρέψει το πανόραμα και να έχει μια πλήρη εικόνα 360 μοιρών, από 

αριστερά προς τα δεξιά. Επίσης σε κάποιο ή κάποια σημεία του πανοράματος 

θα βλέπει ένα κουμπί όπου θα τον μεταφέρει στο επόμενο πανόραμα όπου 

θα βλέπει το επόμενο, κοντινό σημείο. Με αυτό τον τρόπο δημιουργείται ένας 

εικονικός περίπατος σε ολόκληρα τα σημεία του χωριού. Επιπλέον θα έχει την 

πρόσβαση σε ένα μενού για την εμφάνιση πληροφοριών, την προβολή ή 

απόκρυψη ενός χάρτη του χωριού από όπου θα μεταβαίνει απευθείας σε ένα 

σημείο του χωριού αλλά και άλλων στοιχείων. 
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Λόγω του ότι τελικά δημιουργούνται εξαιρετικά ενδιαφέρουσες εφαρμογές, το 

Διαδίκτυο έχει κατακλυστεί από αυτές. Άλλωστε έρευνες έδειξαν ότι 

ιστοσελίδες με εικονική περιήγηση δέχονται περισσότερες επισκέψεις από 

αυτές που δεν έχουν. Κι αυτό γιατί ο χρήστης προτιμά να δει πρώτα το 

δωμάτιο ενός ξενοδοχείου πριν το κλείσει, να δει αξιοθέατα πριν τα επισκεφτεί 

από κοντά, να δει πόλεις πριν τις επισκεφθεί από κοντά και πολλά, πολλά 

άλλα ακόμη.  

 

Ας δούμε μερικά παραδείγματα τέτοιων εφαρμογών. 

 

Περιήγηση στην Νέα Υόρκη των ΗΠΑ. 
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Περιήγηση στο Ντουμπάι. Οι λήψεις των εικόνων πραγματοποιήθηκαν από 

ελικόπτερο. 

 

 

Υποβρύχια εικονική περιήγηση στις Μαλδίβες. 
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Εικονική περιήγηση στις Μαλδίβες. 

 

 

Η πρώτη εικονική περιήγηση κάτω από τον πάγο. 
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Εικονική περιήγηση στην Ακρόπολη. 

 

 

Εικονική περιήγηση σε τηλεοπτικό στούντιο. 
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Για την πραγματοποίηση της παραπάνω εφαρμογής, καταρχάς, έπρεπε να 

επισκεφθώ το χωριό με έναν τρίποδα και μία ψηφιακή φωτογραφική μηχανή. 

Λόγω του ότι δεν είχα στην κατοχή μου κάποια επαγγελματική ψηφιακή 

φωτογραφική μηχανή χρησιμοποίησα μία απλή ψηφιακή φωτογραφική 

μηχανή. Το ίδιο ισχύει για τον τρίποδα. Λόγω αυξημένου κόστους αγοράς 

επαγγελματικού τρίποδα προτίμησα έναν απλό. Το μειονέκτημα του να 

χρησιμοποιήσω απλή ψηφιακή φωτογραφική μηχανή ήταν να μην καλύψω 

μεγάλο οπτικό πεδίο από πάνω προς τα κάτω. 

Στη συνέχεια κι έπειτα από εκτεταμένη έρευνα στο Διαδίκτυο σε διάφορες 

ιστοσελίδες και ιστοσελίδες συζητήσεων βρέθηκα ανάμεσα σε διάφορες 

επιλογές προγραμμάτων. Για την ένωση των εικόνων και τη δημιουργία των 

πανοραμάτων είχα την επιλογή του Hugin. Όμως επειδή είχα το πρόβλημα 

της διαφορετικής έκθεσης διαδοχικών εικόνων δεν μπορούσα να 

επεξεργαστώ την κάθε εικόνα ξεχωριστά. Έτσι κατέληξα στην επιλογή του 

Photoshop λόγω των περισσότερων δυνατοτήτων που προσφέρει και των 

καλύτερων αποτελεσμάτων που παράγει. 

Για την ένωση των πανοραμάτων είχα τις επιλογές ανάμεσα στο Tourweaver, 

στο 3DVista και στο Pano2VR. Δοκιμάζοντάς τα όλα συνειδητοποίησα ότι το 

Pano2VR ήταν πιο απλό κι εύκολο στη χρήση αλλά και το ότι η εταιρία 

διαθέτει στην ιστοσελίδα της διάφορα βίντεο για το πώς μπορείς να κάνεις 

διάφορα πράγματα. Στοιχεία πολύ σημαντικά για έναν αρχάριο χρήστη. Έτσι 

κατέληξα να δημιουργήσω την τελική εφαρμογή με το πρόγραμμα Pano2VR. 
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ΚΕΦΑΛΑΙΟ 2 

Πληροφορίες για το χωριό Νεράιδα 

 

Στη νότια κορυφογραμμή της Πίνδου και στο κέντρο του ορεινού και 

απρόσιτου όγκου των Αγράφων σε υψόμετρο 800-960 μέτρων είναι κτισμένο 

το χωριό Νεράιδα. 

 

Ο πληθυσμός του χωριού, σύμφωνα με την τελευταία απογραφή είναι 173 

κάτοικοι. 
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Απέχει 42 χιλιόμετρα από την πόλη της Καρδίτσας, όσα περίπου κι από το 

Καρπενήσι και διακρίνεται για την πατροπαράδοτη φιλοξενία της και την 

απίθανη φυσική της ομορφιά. 

 

Μια επίσκεψη θα σας πείσει! 
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ΚΕΦΑΛΑΙΟ 3 

Λήψη φωτογραφιών 

 

Για τη λήψη των φωτογραφιών θα χρειαστούμε έναν τρίποδα με αλφάδι και 

μια ψηφιακή φωτογραφική μηχανή. Θα ξεκινήσουμε τοποθετώντας τον 

τρίποδα με την ψηφιακή φωτογραφική μηχανή στο κέντρο του δρόμου σε 

κάποιο σημείο. Προσέχουμε το αλφάδι να είναι σωστά ευθυγραμμισμένο. Ο 

φακός της ψηφιακής φωτογραφικής μηχανής που χρησιμοποίησα ήταν 25mm 

που σημαίνει ότι καλύπτει οπτικό πεδίο 70 μοιρών από τα αριστερά προς τα 

δεξιά. Επομένως για να καλύψω την απόσταση των 360 μοιρών σε κάθε 

σημείο έβγαζα 6 λήψεις. Επίσης η ψηφιακή φωτογραφική μηχανή πρέπει να 

είναι στις χειροκίνητες ρυθμίσεις για να μην υπάρξουν διαδοχικές 

φωτογραφίες με διαφορετική έκθεση και δημιουργηθεί πρόβλημα αργότερα 

στη συρραφή. Στη συνέχεια προχωράμε στο επόμενο σημείο, σε μικρή 

απόσταση για να μην μπερδευτεί ο χρήστης κι επαναλαμβάνουμε ακριβώς τα 

ίδια μέχρι να καλύψουμε ολόκληρο το χωριό. Επίσης προσέχουμε να 

καλύψουμε και τις διασταυρώσεις των δρόμων. Επιπρόσθετα, οι λήψεις 

πρέπει να πραγματοποιηθούν σε συγκεκριμένο χρονικό διάστημα για να μην 

υπάρξουν σημεία με διαφορετικό φως. 
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ΚΕΦΑΛΑΙΟ 4 

Συρραφή φωτογραφιών 

 

Για τη συρραφή των φωτογραφιών θα κάνω χρήση του προγράμματος 

Photoshop. Ανοίγουμε τις 6 εικόνες ενός σημείου και στη συνέχεια πατάμε 

File->Automate->Photo merge. Μετά επιλέγουμε Interactive Layout, Add 

Open Files και ΟΚ. 

 

 

 

Στη συνέχεια ενώνουμε τις εικόνες τη μια με την επόμενη που είναι η συνέχειά 

της. Προσοχή όμως. Ξεχωρίζουμε την πρώτη με την τελευταία εικόνα που τις 

ένωσε αυτόματα. Έτσι ξεκινάμε με την πρώτη εικόνα και καταλήγουμε στην 

τελευταία που είναι σχεδόν κοινή με την πρώτη. Αυτό το κάνουμε για να 

έχουμε πολύ κοινό θέμα όταν κόψουμε το πανόραμα. Δηλαδή με τις 6 εικόνες 

που λήφθηκαν καλύφθηκε απόσταση 420 μοιρών. Επομένως πρέπει να 

κόψουμε ότι περισσεύει. 
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Στη συνέχεια πατάμε ΟΚ και δημιουργείται η παρακάτω εικόνα. 

 

 

Μετά επιλέγουμε την «καθαρή» εικόνα. Πατάμε Edit->Copy Merged και μετά 

File->New->OK και μετά Edit->Paste. 

 

Δεν μας πειράζουν τα άσπρα κενά πάνω και κάτω γιατί αργότερα θα 

εξαλειφθούν με το Crop. Αρκεί όμως να είναι μικρά. 
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Στη συνέχεια διαλέγουμε το σημείο που θα κόψουμε την εικόνα. Φροντίζουμε 

να είναι ακριβώς τα όρια κοιτώντας το Χ και Υ της εικόνας. Δηλαδή εκεί που 

θα τελειώνει η μια άκρη θα πρέπει να αρχίζει η επόμενη. 

 

 

Μετά Edit->Copy Merged μετά File->New->Paste 

 

Μετά πατάμε Crop κι επιλέγουμε ολόκληρη την εικόνα. Κοιτάμε στο Info να 

την περιστρέψουμε τόσες μοίρες ώστε να ενωθούν ακριβώς οι άκρες της. 

Αυτό το κάνουμε κοιτώντας ένα αντικείμενο που τελειώνει στη μια άκρη και 

συνεχίζει στην επόμενη. Στο παράδειγμά μας θα χρειαστεί να την 

περιστρέψουμε 1.2 μοίρες. Αφού πατήσουμε enter για να ολοκληρωθεί το 

crop επιλέγουμε πάλι την «καθαρή» εικόνα. 



Πτυχιακή εργασία του    φοιτητή    Βρέκου Δημήτριου 

 18 από 51 
 

 

 

Πατάμε Edit->Copy Merged μετά File->New->Edit->Paste 
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Στη συνέχεια προσέχουμε εάν στα πανόραμά μας φαίνονται πινακίδες 

αυτοκινήτων ή πρόσωπα και τα θολώνουμε εφαρμόζοντας ένα φίλτρο. 

Επιλέγουμε την περιοχή που θέλουμε να θολώσουμε με το Rectangular 

Marquee Tool ή με το Polygonal Lasso Tool. Μετά επιλέγουμε Filter->Blur-

>Gaussian Blur  και στο Radius επιλέγουμε 13 pixels και πατάμε ΟΚ. 

 

 

Τώρα το πανόραμά μας είναι έτοιμο. Το αποθηκεύουμε σαν εικόνα jpeg. 
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ΚΕΦΑΛΑΙΟ 5 

Ένωση πανοραμάτων 

 

Για την ένωση τον πανοραμάτων θα χρησιμοποιήσουμε το πρόγραμμα 

Pano2VR.  Το πρώτο που θα κάνουμε είναι θα δημιουργήσουμε το flash κάθε 

πανοράματος.  

 

Επιλέγουμε Επιλέξατε Δεδομένα. Στη συνέχεια στο Πανόραμα επιλέγουμε 

Άνοιγμα κι επιλέγουμε το πανόραμά μας. Μετά στο Νέα Μορφή Εξόδου 

επιλέγουμε Flash. Πατάμε Προθήκη και ΟΚ. Τώρα δημιουργήθηκε το αρχείο 

Pano2VR όπου μπορούμε να τροποποιήσουμε το flash αλλά κι ένας φάκελος 

output όπου περιέχει το τελικό flash. 
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Ας δούμε τώρα τι επιλογές έχουμε. 

 

Το Παράμετροι Παρουσίασης είναι για να τροποποιήσουμε το οπτικό πεδίο. 

Δηλαδή ποιο σημείο του πανοράματος θα δείχνει μόλις ανοίγει το flash. 

Επίσης μπορούμε να ορίσουμε και τον Βορρά γυρίζοντας το πανόραμα να 

δείχνει εκεί που είναι ο Βορράς και πατώντας ρύθμιση. 
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Στο Δεδομένα Χρήστη μπορούμε να δώσουμε διάφορες πληροφορίες. 

 

Πατώντας το κόκκινο κουμπί δίπλα στο Γεωγραφικό Πλάτος μπορούμε να 

ορίσουμε σε χάρτη που ακριβώς βρίσκεται το σημείο που δείχνει το 

πανόραμά μας. 
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Στο Ενεργές Ζώνες μπορούμε να συνδέσουμε πανοράματα και να φτιάξουμε 

εικονική περιήγηση. 

  

Για να γίνει αυτό κάνουμε διπλό κλικ στο σημείο που θέλουμε να 

τοποθετήσουμε το κουμπί που θα μας οδηγεί στο επόμενο πανόραμα. Στη 

Διεύθυνση (URL) βάζουμε το όνομα του πανοράματος και στο Στόχο το 

_parent. Το _parent το βάζουμε για να ανοίξει το πανόραμα στο τρέχων 

παράθυρο. Για να μην μπερδευτούμε όμως κωδικοποιούμε τα πανοράματα. 

Π.χ. τα πανοράματα του κεντρικού δρόμου τα ονομάζουμε kd1, kd2 και ούτω 

καθεξής. Αυτό το κάνουμε σε όλα τα πανοράματα. Επίσης μπορεί να 

χρειαστούν περισσότερα του ενός κουμπιά όπως στην παρακάτω εικόνα. 
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Στο Πολυμέσα μπορούμε να ορίσουμε ένα βίντεο να παίζει σε κάποιο σημείο 

του πανοράματός μας ή κάποιος ήχος όπως μία περιγραφή του τι βλέπουμε 

σε αυτό το σημείο. 
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Δεξιά στον Διαφυλλιστή Περιήγησης βλέπουμε τα πανοράματα που έχουμε 

εισάγει. 

 

 Όταν θέλουμε να φτιάξουμε μια εικονική περιήγηση θα χρειαστούμε 

περισσότερα του ενός πανοράματα κι αυτά εμφανίζονται εκεί. Έτσι όμως 

δημιουργείται ένα τελικό flash αρχείο που περιέχει όλα τα πανοράματα μαζί. 

Σε μία εφαρμογή όπως η δικιά μας που αποτελείται από πάρα πολλά 

πανοράματα αυτός ο τρόπος θα δημιουργήσει ένα μεγάλο σε μέγεθος αρχείο 

flash. Επομένως δημιουργούμε για κάθε πανόραμα το flash αρχείο του και τα 

ενώνουμε καλώντας το ένα με το άλλο. 
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Στη συνέχεια θα προσθέσουμε κάποια επιπλέον στοιχεία στην εφαρμογή μας. 

Επιλέγουμε Εργαλεία->Επεξεργαστής επιδερμίδας(skin) 

 

Επιλέγουμε Αρχείο->Άνοιγμα κι επιλέγουμε το αρχείο simplex.ggsk 

 

Όπως βλέπουμε κι από την παραπάνω εικόνα, δεξιά στο Δέντρο βλέπουμε τα 

στοιχεία που θα προστεθούν στην εφαρμογή μας. 
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Το controller είναι όλα τα κουμπιά για την περιστροφή του πανοράματος 

δεξιά, αριστερά, πάνω και κάτω, για την μεγέθυνση και σμίκρυνση, για την 

αυτόματη περιστροφή, για την εμφάνιση πληροφοριών, για την αλλαγή 

κατάστασης και για την πλήρη οθόνη. Το κάθε ένα έχει την δική του 

ταυτότητα. Π.χ. το κουμπί της μεγέθυνσης το ονομάσαμε zoomin. Εάν 

κάνουμε διπλό κλικ σε ένα στοιχείο τότε θα δούμε τις ρυθμίσεις. 

  

Π.χ. στο zoomin που είναι για την μεγέθυνση βλέπουμε ότι μπορούμε να 

αλλάξουμε την εικόνα που θα έχει, το μέγεθός του και άλλα. 
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Στην καρτέλα Ενέργειες/Τροποποιητές ρυθμίσουμε τις ενέργειες που θα κάνει 

το κουμπί. Στην Εμφάνιση Στόχου το tt_zoomin είναι η ταυτότητα του 

πλαισίου κειμένου που θα εμφανίζεται. 

Εάν κάνουμε διπλό κλικ στο tt_zoomin βλέπουμε τις ρυθμίσεις για το κείμενο 

του κουμπιού όπως το κείμενο που θα εμφανίζεται όταν ο χρήστης έχει το 

ποντίκι στο πλήκτρο της μεγέθυνσης. 

 

Υπάρχουν δύο tt_zoomin με διαφορετικό χρώμα για να δημιουργηθεί ενός 

είδους εφέ. 
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Το loading δείχνει πόσο τοις εκατό ολοκληρώθηκε η φόρτωση ολόκληρου του 

πανοράματος. Θα εμφανίζεται μόνο όταν ανοίγουμε το πανόραμα. 

 

To userdata εμφανίζει τις πληροφορίες που έχουμε εισάγει κατά τη 

δημιουργία του πανοράματος. Μπορούμε να ρυθμίσουμε ποιου είδους 

πληροφορίες θα εμφανίζονται.  

 

 

Το hotspot είναι το κουμπί που θα εμφανίζεται για να μεταφερθούμε στο 

επόμενο πανόραμα. Για να βάλουμε τη δικιά μας εικόνα στο κουμπί κάνουμε 

διπλό κλικ στο hsimage και στο πεδίο Εικόνα πατάμε αλλαγή. Επιλέγουμε την 

εικόνα που θέλουμε και πατάμε ΟΚ. Όμως οι εικόνες που μας αφήνει να 

επιλέξουμε πρέπει να έχουν κατάληξη .svg. Εάν θέλουμε να μετατρέψουμε 



Πτυχιακή εργασία του    φοιτητή    Βρέκου Δημήτριου 

 30 από 51 
 

μια jpeg εικόνα σε svg πρέπει να έχουμε εγκατεστημένο το κατάλληλο 

πρόγραμμα. Για αυτήν την αλλαγή χρησιμοποίησα το Inkscape όπου άνοιξα 

την εικόνα που ήθελα και στη συνέχεια την αποθήκευσα ως svg. Στη συνέχεια 

κάνουμε διπλό κλικ στο hstext και εισάγουμε το κείμενο που θέλουμε να 

εμφανίζει όταν έχουμε το ποντίκι στο κουμπί. Π.χ. πληκτρολογούμε το 

«Επόμενο Πανόραμα». 

 

Το hide_template είναι για τους κόμβους που θα μας μεταφέρουν σε άλλα 

πανοράματα. Δηλαδή μπορούμε να εισάγουμε κάποιον χάρτη και μετά να του 

τοποθετήσουμε κόμβους όπου ο χρήστης θα μεταφέρεται σε όποιον κόμβο 

του χάρτη επιθυμεί. Ας δούμε στη συνέχεια πως φτιάχνουμε τον χάρτη. Θα 

χρησιμοποιήσω τον παρακάτω πολεοδομικό χάρτη του χωριού. 
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Από το Εργαλεία επιλέγουμε το Προσθήκη εικόνας. Στη συνέχεια επιλέγουμε 

την εικόνα που θέλουμε να χρησιμοποιήσουμε ως χάρτη. Η εικόνα δεν πρέπει 

να έχει μεγάλες διαστάσεις αλλά ούτε και πολύ μικρές. 

 

Τοποθετούμε τον χάρτη πάνω αριστερά προσέχοντας να έχει μικρά κενά 

πάνω κι αριστερά. Στην Αγκύρωση επιλέγουμε το πάνω αριστερό τετράγωνο. 

Αυτό σημαίνει ότι ο χάρτης θα εμφανίζεται στην πάνω αριστερή γωνία του 

πανοράματος. Στη συνέχεια κάνουμε διπλό κλικ στο marker_active και στο 

Εικόνα πατάμε αλλαγή κι επιλέγουμε την εικόνα που θέλουμε να εμφανίζεται 

όταν αυτός ο κόμβος είναι ενεργός. 

 

Το ίδιο κάνουμε και στο marker_normal δηλαδή η εικόνα που θα εμφανίζεται 

όταν ο κόμβος είναι ανενεργός. 
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Μετά, από τα Εργαλεία επιλέγουμε Προσθήκη Δείκτη Κόμβου. Κάνουμε διπλό 

κλικ και στο Δημιουργία Κλώνου κανονικά επιλέγουμε marker_normal και στο 

Δημιουργία Κλώνου ως Ενεργού επιλέγουμε το marker_active. Έτσι ο κόμβος 

θα πάρει τη μορφή με τις εικόνες που επιλέξαμε πριν. Στη συνέχεια, με τον 

ίδιο τρόπο, δημιουργούμε τόσους κόμβους όσους χρειαζόμαστε και τους 

τοποθετούμε πάνω στο χάρτη στα σημεία που επιθυμούμε. 

 

Επίσης από τα Εργαλεία επιλέγουμε Σχεδίαση πεδίου κειμένου. Το 

ονομάζουμε marker_title και το τοποθετούμε κάτω από το marker_node1. 

Κάνουμε διπλό κλικ και εισάγουμε το κείμενο που θέλουμε να εμφανίζεται. 

Π.χ. Κεντρική Πλατεία. Μετά κάνουμε διπλό κλικ στο marker_node1 και στο 

πεδίο Κόμβος Περιήγησης/Ετικέτα βάζουμε το όνομα του πανοράματος που 

θέλουμε να μας εμφανίσει όταν πατήσουμε στον κόμβο. 
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Στην καρτέλα Ενέργειες/Τροποποιητές προσθέτουμε τις ενέργειες που 

βλέπουμε στην παρακάτω εικόνα. Αυτές είναι για να εμφανίζεται το κείμενο 

όταν έχουμε το ποντίκι στον κόμβο και να εξαφανίζεται όταν δεν έχουμε το 

ποντίκι στον κόμβο. Στο στόχο βάζουμε την ταυτότητα του πεδίου κειμένου. 
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Στη συνέχεια θα δημιουργήσουμε ένα κουμπί όπου θα εμφανίζει και θα 

αποκρύπτει τον χάρτη. Από τα Εργαλεία επιλέγουμε Σχεδίαση Υποδοχέα κι 

επιλέγουμε ολόκληρο τον χάρτη με τους κόμβους του. Επίσης δεξιά στο 

δέντρο το ονομάζουμε map. Αυτό το κάνουμε για να διαχειριστούμε αργότερα 

ολόκληρο τον χάρτη με τους κόμβους του σαν ένα. Μετά από τα εργαλεία 

επιλέγουμε Προσθήκη κουμπιού κι επιλέγουμε την εικόνα που θέλουμε να έχει 

το κουμπί. Στη συνέχεια, δεξιά στο δέντρο, το μεταφέρουμε στον controller και 

αριστερά στον επεξεργαστή το τοποθετούμε δίπλα στο κουμπί της πλήρης 

οθόνης. 
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Μετά κάνουμε διπλό κλικ στο κουμπί. Στο πεδίο Ποντίκι Επάνω επιλέγουμε 

την ίδια εικόνα  αλλά πιο μεγάλη σε μέγεθος για να δημιουργηθεί εφέ όταν θα 

πηγαίνουμε το ποντίκι επάνω στο κουμπί. Στην καρτέλα 

Ενέργειες/Τροποποιητές στην προέλευση επιλέγουμε κλικ ποντικιού, στο 

πεδίο ενέργειες επιλέγουμε εναλλαγή ορατότητας πεδίου και στο στόχο 

βάζουμε την ταυτότητα του χάρτη δηλαδή το map. Το showhidemap είναι η 

ταυτότητα του κειμένου που θα εμφανίζεται. 

 

 

 

Στη συνέχεια πατάμε ΟΚ κι αποθηκεύουμε την επιδερμίδα που φτιάξαμε με 

ότι όνομα θέλουμε. Μετά πατάμε προσθήκη και στη καρτέλα ρυθμίσεις, στην 

επιδερμίδα επιλέγουμε το όνομα της επιδερμίδας που φτιάξαμε. 
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Επίσης στην καρτέλα Οπτικά επιλέγουμε το Ενεργοποίηση μεταβάσεων. Έτσι 

θα δημιουργηθεί ένα εφέ όταν θα μεταβαίνουμε από το ένα πανόραμα στο 

άλλο. 

 

 

Τη διαδικασία αυτή την επαναλαμβάνουμε για όλα τα πανοράματα που 

έχουμε δημιουργήσει. Δεν χρειάζεται όμως να φτιάξουμε καινούρια 

επιδερμίδα. Απλά εισάγουμε στα επόμενα πανοράματα αυτή που έχουμε ήδη 

φτιάξει μία φορά. 
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ΚΕΦΑΛΑΙΟ 6 

Τα προβλήματα που αντιμετώπισα 

 

Το πρώτο πρόβλημα που αντιμετώπισα ήταν αυτό του ορίζοντα. Δηλαδή ενώ 

χρησιμοποίησα τρίποδα κι απλά περιέστρεφα από αριστερά προς τα δεξιά 

την ψηφιακή φωτογραφική μηχανή οι φωτογραφίες δεν βγήκαν σωστά 

ευθυγραμμισμένες η μια με την άλλη. 

 

Όπως βλέπουμε από την παραπάνω εικόνα κατά την ένωση δημιουργήθηκαν 

κενά πάνω και κάτω. Αυτό θα το λύσουμε με το Crop. Θα κοιτάξουμε ένα 

αντικείμενο που κόβεται στη μια άκρη και συνεχίζει στην επόμενη. Στη 

συνέχεια κοιτάμε στο Info στις πόσες μοίρες θα ευθυγραμμιστεί το 

αντικείμενο. Έτσι όμως θα λυθεί μερικώς το πρόβλημα γιατί δεν θα 

ευθυγραμμιστεί ολόκληρη η εικόνα επειδή το ένα άκρο έχει περισσότερο θέμα 

πάνω και κάτω. Το μειονέκτημα της όλης διαδικασίας είναι να μειωθεί αισθητά 

το οπτικό πεδίο του τελικού πανοράματος της εφαρμογής. 
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Το δεύτερο πρόβλημα που αντιμετώπισα ήταν αυτό της διαφορετικής έκθεσης 

των φωτογραφιών όπως βλέπουμε στην παρακάτω εικόνα. 

 

 

Δηλαδή βάζοντας τη μια εικόνα δίπλα στην άλλη για να δημιουργήσουμε το 

τελικό πανόραμα παρατηρούμε ότι η μια είναι πιο σκούρα ή ανοιχτή από την 

επόμενη ή προηγούμενη. Έτσι σκουραίνουμε τις ανοιχτές εικόνες για να έχουν 

την ίδια έκθεση με τις άλλες. Αυτό το κάνουμε ανοίγοντας την σκούρα κι 

ανοιχτή εικόνα στο Photoshop. Μετά επιλέγουμε Image->Adjustments-

>Levels. Μετά πειράζουμε το Input Levels και το Output Levels μέχρι η 

έκθεση της φωτογραφίας να σκουρύνει στο επιθυμητό επίπεδο. Μετά 

αποθηκεύουμε τις εικόνες κι ανοίγουμε τις υπόλοιπες για να δημιουργήσουμε 

το τελικό πανόραμα με την ίδια διαδικασία που περιγράψαμε πιο πάνω. 

 

 

Πατώντας ΟΚ στο Photo merge δημιουργείται η παρακάτω εικόνα με το 

πρόβλημα να έχει σχεδόν εξαλειφθεί. 
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Όμως εάν ενώσουμε το τελικό πανόραμα στο Pano2VR τότε θα 

παρατηρήσουμε ότι δημιουργείται πάλι το πρόβλημα της έκθεσης. 

 

 

Για να το λύσουμε αυτό κόβουμε το τελικό πανόραμα σε δύο εικόνες σε 

κάποιο σημείο που είναι δύσκολο να παρατηρήσει κάποιος κάποια αλλαγή. 

 

 

 

 

 

 



Πτυχιακή εργασία του    φοιτητή    Βρέκου Δημήτριου 

 40 από 51 
 

Μετά ανοίγουμε τις δύο αυτές εικόνες στο Photoshop και τις κάνουμε Photo 

merge στο σημείο που έχουμε το πρόβλημα της έκθεσης. 

 

Όπως βλέπουμε από την παραπάνω εικόνα το πρόβλημα της έκθεσης 

διορθώθηκε. Την ίδια διαδικασία ακολουθούμε σε όλες τις εικόνες και σε όλα 

τα πανοράματα που έχουν πρόβλημα έκθεσης. 

 

Ένας άλλος τρόπος αντιμετώπισης του προβλήματος της έκθεσης είναι ο 

εξής. 
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Αυτό το αντιμετωπίζουμε ως εξής. Κόβουμε από την αρχή του πανοράματος 

μόνο το κομμάτι που είναι σκούρο και από το τέλος ένα μικρό κομμάτι που 

είναι πιο ανοιχτό. 

 

                       

 

Στη συνέχεια από το μενού Image->Adjustments->Levels κάνουμε πιο ανοιχτή 

τη σκούρα εικόνα έχοντας την ανοιχτόχρωμη δίπλα. Μετά αντιγράφουμε το 

κομμάτι που φτιάξαμε στο τελικό πανόραμα. 

 

 

 

 

 

 

 

 



Πτυχιακή εργασία του    φοιτητή    Βρέκου Δημήτριου 

 42 από 51 
 

Όπως βλέπουμε από την παρακάτω εικόνα το πρόβλημα διορθώθηκε και δεν 

είναι έντονη η διαφορά της έκθεσης. 
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ΚΕΦΑΛΑΙΟ 7 

Η εφαρμογή στο Διαδίκτυο 

 

Τώρα θα δούμε πως εμφανίζεται η εφαρμογή σε κάποιον φυλλομετρητή. 

 

Στην αρχή θα εμφανίζεται το μενού όπου ο χρήστης θα επιλέγει ότι επιθυμεί. 

 

 

 

 

 

 

 

 

 

 

 

 

 



Πτυχιακή εργασία του    φοιτητή    Βρέκου Δημήτριου 

 44 από 51 
 

Πατώντας στο «περιήγηση στο χωριό» ο χρήστης θα περιηγείται στο χωριό 

όπως βλέπουμε στις παρακάτω εικόνες. 
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Πατώντας στο «Ιερά Μονή Γεννήσεως Θεοτόκου» θα περιηγείται στο 

μοναστήρι. 

 

 

 

 

 

 

 

 

 



Πτυχιακή εργασία του    φοιτητή    Βρέκου Δημήτριου 

 47 από 51 
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Πατώντας στο εξωκκλήσι του Σωτήρος θα περιηγείται στο εξωκκλήσι. 
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ΣΥΜΠΕΡΑΣΜΑΤΑ 

 

Η πτυχιακή ξεκίνησε μη γνωρίζοντας σχεδόν τίποτα. Ψάχνοντας όμως πολύ 

στο Διαδίκτυο απέκτησα γνώσεις για το πώς πρέπει να κάνω τη λήψη των 

φωτογραφιών βήμα-βήμα και πως πρέπει να τις συρράψω για να 

δημιουργήσω το τελικό πανόραμα. Έτσι απέκτησα αρκετές γνώσεις και 

προχώρησα στην υλοποίησή της. 

Μάλιστα έκανα λήψη πάνω από 2300 εικόνες κι έφτιαξα πάνω από 150 

πανοράματα για να καλύψω ολόκληρο το χωριό αλλά και δύο εξωκκλήσια του. 

Η τελική εφαρμογή που δημιουργήθηκε είναι αρκετά ικανοποιητική. Υπάρχουν 

όμως κάποια προβλήματα που θα μπορούσαν να είχαν αποφευχθεί όπως η 

διαφορά της έκθεσης σε διαδοχικές εικόνες. 
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ΒΙΒΛΙΟΓΡΑΦΙΑ 

 

http://www.google.com 

http://help.360cities.net/taking-panoramic-pictures/how-to-get-started 

http://www.panomonkey.com/panorama-software/how-to-shoot-panoramic-photos 

http://www.photographyblog.com/articles/how_to_take_great_panorama_photos/ 

http://ggnome.com/forum/ 

http://ggnome.com/wiki/Pano2VR_Tutorials 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 


